Entlib version mismatch?

Aug 22, 2011 at 2:18 PM

Hi I'm attempting to use the Import WSDL extension in VS2010. The WSDL seems to have been imported okay but when attempting to generate code from the service contract model you get serveral validation errors of the form:

Error 1 Unable to cast object of type 'Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSyntheticConfigSettings' to type 'Microsoft.Practices.EnterpriseLibrary.Common.Configuration.ContainerModel.ITypeRegistrationsProvider'.

The only reason I can think of for that to occur is mismatched assembly versions since DatabaseSyntheticConfigSettings does in fact implement ITypeRegistrationsProvider.

Help anyone?